Company Logo

System Requirements

This table outlines the requirements for using the FastTest system. In some cases, older versions of the applications will work; however, these are not officially supported by FastTest. Logins will be disabled automatically if your computer fails to meet the requirements. A message will be displayed instructing you how to fix the problem.
RequirementSupported
Web Browser
Mozilla FirefoxLatest Version
Google ChromeLatest Version
Apple SafariLatest Version
Microsoft EdgeLatest Version
Adobe Flash Plug-inVersion 9.0.115+
JavaScriptMust be enabled; automatically included with supported browsers
CookiesMust be enabled; supported in the above browsers
Screen Resolution1024 × 768+